Back to overview
Degraded
[external] ING bank is not operational
Oct 20 at 09:22am CEST
Affected services
Checkout
Resolved
Oct 21 at 08:31am CEST
The issue was resolved by the bank.
Affected services
Created
Oct 20 at 09:22am CEST
ING bank is currently not operational, we will update the status as soon as the issue is resolved on their side
Affected services