Back to overview
Degraded

[external] Commerzbank Outage

Oct 09 at 09:31am CEST
Affected services
Checkout

Resolved
Oct 09 at 02:35pm CEST

The Commerzbank outage has now been resolved. We apologise for any inconvenience.

Created
Oct 09 at 09:31am CEST

There is a major outage with Commerzbank going on right now. The issue is identified and the fix is being worked on right now.

We will inform you as soon as a change to the situation occurs.