Back to overview
Degraded

Settlement times for FX are delayed

Oct 01 at 02:37pm CEST
Affected services
API

Resolved
Oct 01 at 09:21pm CEST

Third party provider has resolved issue affecting settlement times across the EVM networks: Ethereum and Polygon. All in-transit EMV network settlements have successfully processed.

Created
Oct 01 at 02:37pm CEST

Settlement times for FX are delayed due to delays of a 3rd party provider. This affects settlement times across the EVM networks: Ethereum and Polygon.