Back to overview
Degraded
N26 payment initiation outage
Sep 29 at 12:17pm CEST
Affected services
Checkout
Resolved
Sep 29 at 12:55pm CEST
N26 issue resolved
Affected services
Created
Sep 29 at 12:17pm CEST
We are currently investigating an issue with N26 that affects Payment Initiation.
Affected services