Back to overview
Degraded

Maintenance Window of an underlying provider for FX Settlement taking longer than expected

Aug 28 at 10:48am CEST
Affected services
API

Resolved
Aug 28 at 12:28pm CEST

Maintenance has been completed and the issues have been resolved.

Created
Aug 28 at 10:48am CEST

A maintenance window scheduled by a core provider for the FX Settlement product is taking longer than expected. This will result in settlement delays. We will update as soon as we have more information.