Back to overview
Degraded
Payment processing times are increased
Aug 18 at 04:12pm CEST
Affected services
API
Resolved
Aug 18 at 04:29pm CEST
The issue has been resolved by our partner and payments are settling instantly again.
Affected services
Created
Aug 18 at 04:12pm CEST
We currently see increased payment processing times with one of our bank providers. We have already escalated this and are investigating this with their team.
We will keep you posted here, as soon as we know more.
Affected services