Back to overview
Degraded

Payment Processing Delays

Apr 2, 2026 at 1:47pm UTC
Affected services
API

Resolved
Apr 2, 2026 at 3:33pm UTC

We resolved the issue with pending or authorized payments for DE and GB IBANs. Our provider's services are fully operational, and all affected transactions have been or will soon be processed.

Created
Apr 2, 2026 at 1:47pm UTC

We are momentarily experiencing an outage with one of our Bank Providers causing payments to stick in pending or in authorised state for our DE and GB IBANS.

We are working on resuming services to you as soon as possible and will notify you when our services are fully operational again!