Back to overview
Degraded

Settlement times for FX are delayed

Mar 26, 2026 at 9:43am UTC
Affected services
API

Resolved
Mar 26, 2026 at 1:15pm UTC

Settlement times for FX are back to normal.

Created
Mar 26, 2026 at 9:43am UTC

We are momentarily experiencing an outage with one of our Bank Providers causing payments to stick in pending or in authorised state for our DE and GB IBANS.

We are working on resuming services to you as soon as possible and will notify you when our services are fully operational again!