Back to overview
Degraded

Investigating: Settlement Delays with one of our Banking Partners

Mar 17, 2026 at 11:28am UTC
Affected services
API

Resolved
Mar 17, 2026 at 1:59pm UTC

Our banking partner has confirmed that the underlying processing issue is now fixed.
Full service has been restored. We will continue to monitor the settlement flow to ensure continued stability.

Created
Mar 17, 2026 at 11:28am UTC

We are currently investigating an issue where certain inbound payment notifications are not being processed correctly. This is causing a delay in transaction status updates for some users.