Back to overview
Degraded

Settlement times for FX are delayed

Feb 25, 2026 at 11:18am UTC
Affected services
API

Resolved
Feb 25, 2026 at 2:24pm UTC

Settlement times for FX are back to normal.

Created
Feb 25, 2026 at 11:18am UTC

Settlement times for FX are delayed. We're working on fixing the issue.