Back to overview
Degraded
Checkouts for some merchants are failing due to account setup issues
Feb 20, 2026 at 11:39am UTC
Affected services
Checkout
Resolved
Feb 20, 2026 at 12:07pm UTC
We've confirmed the issue has been resolved.
Affected services
Updated
Feb 20, 2026 at 12:01pm UTC
We have released the fix and are monitoring
Affected services
Created
Feb 20, 2026 at 11:39am UTC
We have identified the issue and are releasing a fix shortly. ETA 15 min.
Affected services