SEPA Instant Settlement Delays
Resolved
Jan 22 at 07:18pm CET
The issue is resolved. We are monitoring the situation.
Affected services
Updated
Jan 22 at 06:32pm CET
The issue is identified and being addressed. Most payments are settling already again. We expect the issue to be resolved within the next hour for all remaining payments. Thank you for the patience.
Affected services
Updated
Jan 22 at 03:26pm CET
We are still in contact with our Partner to figure out the issue. We will provide you with an ETA as soon as we know more.
Affected services
Created
Jan 22 at 03:14pm CET
We see SEPA Instant Payments not settling within the past 30 minutes with one of our partner banks. We assume that these are technical difficulties which mean that all Payments settle, but notifications are delayed.
We are currently confirming this with our partner. Thank you for your patience.
Affected services