Back to overview
Degraded

Delayed Payments Processing

Nov 13 at 08:45am CET
Affected services
API

Resolved
Nov 13 at 09:20am CET

The fix is released and working. We do not see any issues anymore in processing speed. We are monitoring the situation further and check if retrospective fixes are needed.

Thank you for the patience

Updated
Nov 13 at 09:06am CET

We have identified the root cause and are working on a fix right now.

We will update you once the fix is released.

Created
Nov 13 at 08:45am CET

We see delayed payment processing since roughly 5:37am. The team is fixing this with highest priority. We will give you a heads up as soon as we know more.