Back to overview
Degraded
Deutsche Bank, Norisbank and Postbank - Major Outage
Jul 18 at 10:40pm CEST
Affected services
Checkout
Resolved
Jul 19 at 08:34am CEST
The issue has been resolved. We apologize for the inconvenience.
Affected services
Created
Jul 18 at 10:40pm CEST
We are currently investigating an issue with Deutsche Bank, Norisbank and Postbank that affects Payment Initiation.
Affected services