Back to overview
Degraded
Revolut EU Service Disruption
Jun 12 at 10:04am CEST
Affected services
Checkout
Resolved
Jun 12 at 09:00pm CEST
The issue has been resolved by the bank. The Integration is working fine again.
Affected services
Updated
Jun 12 at 10:04am CEST
We are aware of a service disruption impacting Revolut EU. We have isolated this to an issue on their end, and have escalated to them accordingly. We will update you as more information becomes available.
Affected services
Created
Jun 12 at 10:04am CEST
We are aware of a service disruption impacting Revolut EU. We have isolated this to an issue on their end, and have escalated to them accordingly. We will update you as more information becomes available.
Affected services